Reporting Accessibility

Incident Report for Dispatch

Resolved

Our third party reporting provider has resolved the outage.
Posted Jan 07, 2025 - 09:26 EST

Investigating

Our third party reporting provider is experiencing an outage which may impact reports in Dispatch Work and Manage. We are actively investigating the issue with the provider.
Posted Jan 07, 2025 - 09:23 EST
This incident affected: Dashboards and Reports.