Notifications, Inbox, and Outbound Connector Message Delays

Incident Report for Dispatch

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 21:44 EDT

Monitoring

We are seeing resolution of the earlier delays.

We will continue to monitor and will provide additional updates as needed.
Posted Sep 24, 2025 - 21:12 EDT

Investigating

We are currently experiencing a delay in sending Notifications including Inbox messages. Some enterprise customers may also experience delays in picking up messages.

Users may not be able to access Calendar Events in Manager and Field.
Posted Sep 24, 2025 - 20:27 EDT
This incident affected: Notifications (Email, SMS, Inbox), Integration and Auxiliary APIs (Connector Integration Endpoints), and Cloud Providers and 3rd Party Providers (Third Party Integrations and Providers).