Partner Outage

Incident Report for Dispatch

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:39 EST

Identified

Due to an issue at Cloudflare users may experience intermittent issues on Web and Mobile, including payment processing pages.
Posted Nov 18, 2025 - 08:32 EST
This incident affected: Web and Mobile Apps (Mobile Applications, Web Applications).