Application Accessibility
Incident Report for Dispatch
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 17, 2019 - 10:06 EDT
Monitoring
Some back-end services have been adjusted to address application usability. Our team is actively monitoring the situation and showing signs that users are able to operate as normal.
Posted 3 months ago. Apr 17, 2019 - 09:46 EDT
Investigating
Some users have reported challenges reliably using our web application. We're actively investigating the issue and will provide an update shortly.
Posted 3 months ago. Apr 17, 2019 - 09:29 EDT
This incident affected: Web Application.