Notification Delay

Incident Report for Dispatch

Resolved

The incident is resolved and notifications are sending on time.
Posted Jun 15, 2026 - 17:21 EDT

Investigating

Notifications are currently delayed. We are investigating the cause.
Posted Jun 15, 2026 - 15:33 EDT
This incident affected: Notifications (Email, SMS, Inbox, Notifications Events).