Reporting Accessibility

Incident Report for Dispatch

Resolved

This incident has been resolved
Posted Jan 07, 2025 - 11:08 EST

Investigating

We are activetly investigating an issue with accessing reports in Dispatch Work and Manage. Users may not have access to reports at this time.
Posted Jan 07, 2025 - 10:01 EST
This incident affected: Dashboards and Reports.