Application Accessibility
Incident Report for Dispatch
Resolved
Access has been restored to normal operation for our Web and Mobile apps.
Posted 11 days ago. Aug 07, 2019 - 13:42 EDT
Investigating
Users may be experiencing issues accessing Web and Mobile applications across the platform. Our team is actively investigating - we'll provide an update shortly.
Posted 11 days ago. Aug 07, 2019 - 13:27 EDT
This incident affected: Mobile Applications and Web Application.