API Slowness
Incident Report for Dispatch
Resolved
All operations of Dispatch are back to normal. Users should expect normal interaction and speed performance in the application.
Posted over 1 year ago. Mar 03, 2017 - 16:20 EST
Monitoring
User experience should be back to normal. Our engineers are monitoring the situation while further investigating the root cause.
Posted over 1 year ago. Mar 03, 2017 - 16:01 EST
Identified
We've identified the slow behavior of our web application and have identified the cause. Our engineers are actively working to resolve the service interruption.
Posted over 1 year ago. Mar 03, 2017 - 15:53 EST
Investigating
We're experiencing some slowness in our API. The impact is that a portion of API requests will be slow on the desktop application. The application is still usable, but will take longer to update.
Posted over 1 year ago. Mar 03, 2017 - 15:04 EST