Application Slow Response
Incident Report for Dispatch
Resolved
Services have been restored to normal operation for Web and Mobile applications.
Posted 24 days ago. Jul 25, 2019 - 16:24 EDT
Investigating
Users may be experiencing slow responses with Mobile and Web applications. Our team is actively working on returning services to normal operation.
Posted 24 days ago. Jul 25, 2019 - 15:58 EDT
This incident affected: API Availability, Mobile Applications, and Web Application.