Notification Delay
Incident Report for Dispatch
Resolved
Email & SMS notification delays have been resolved. Operations are now back to normal and we've processed sending of our notification backlog.
Posted 2 months ago. Mar 19, 2019 - 15:50 EDT
Investigating
Our team has picked up on an issue related to the timely delivery of Email & SMS notifications. An investigation is in progress and we're currently seeing a notification delay of several minutes.
Posted 2 months ago. Mar 19, 2019 - 15:27 EDT
This incident affected: Notifications (Email, SMS).