Application Accessibility
Incident Report for Dispatch
Resolved
This incident has been resolved
Posted Nov 20, 2023 - 11:08 EST
Identified
Users may be experiencing issues accessing our Web application, work.dispatch.me, and Mobile apps. We are working on the issue now.
Posted Nov 20, 2023 - 11:05 EST
This incident affected: Mobile Applications and Web Application.