Application Accessibility
Incident Report for Dispatch
Resolved
This incident has been resolved.
Posted Jul 21, 2022 - 13:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2022 - 11:25 EDT
Investigating
Users may be experiencing issues accessing our Web application and Mobile apps. Our team is actively investigating - we'll provide an update shortly.
Posted Jul 21, 2022 - 11:18 EDT
This incident affected: Mobile Applications and Web Application.