Application Accessibility
Incident Report for Dispatch
Resolved
This incident has been resolved.
Posted May 20, 2020 - 09:16 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2020 - 08:46 EDT
Investigating
Users may be experiencing issues accessing our Web application, work.dispatch.me. Our team is actively investigating - we'll provide an update shortly.
Posted May 20, 2020 - 08:39 EDT
This incident affected: Web Application.