Scheduling and Status Issues

Incident Report for Dispatch

Resolved

This incident has been resolved
Posted Jan 02, 2025 - 12:46 EST

Investigating

Please note users may be seeing issues with scheduling and statusing jobs. We are currently investigating and will provide an update shortly.
Posted Jan 02, 2025 - 12:28 EST
This incident affected: Mobile Applications and Web Application.