Outbound Notification Delay
Incident Report for Dispatch
Resolved
Notification deliverability delays have been resolved.
Posted 3 months ago. Jan 16, 2019 - 15:45 EST
Investigating
Our team has begun investigating a recent delay in notifications. At the moment we're seeing delays reaching several minutes but are working to identify and address as quickly as possible.
Posted 3 months ago. Jan 16, 2019 - 15:35 EST
This incident affected: Notifications (Email).