We're investigating intermittent latency issues in our web and mobile application
Incident Report for Dispatch
Resolved
This incident has been resolved.
Posted 10 months ago. Jan 15, 2018 - 12:56 EST
Monitoring
We've increased our hardware resources and have mitigated the issue. Some users may continue to experience intermittent issues as we recover. We are actively monitoring the situation.
Posted 10 months ago. Jan 15, 2018 - 12:40 EST
Investigating
We are currently investigating this issue.
Posted 10 months ago. Jan 15, 2018 - 11:27 EST