Reporting Accessibility

Incident Report for Dispatch

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 12:33 EST

Monitoring

A fix has been deployed and we are monitoring.
Posted Jan 06, 2026 - 12:24 EST

Identified

Our third party reporting provider is experiencing an outage which impacts reporting in Dispatch Manage and Work. We are actively investigating the issue with the provider.
Posted Jan 06, 2026 - 12:07 EST
This incident affected: Cloud Providers and 3rd Party Providers (Dashboards and Reports).