Sending of Billing Documents
Incident Report for Dispatch
Resolved
The issue has been resolved, enabling users to send estimates & invoices to recipients as normal.
Posted 3 months ago. Aug 30, 2018 - 21:34 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Aug 30, 2018 - 20:31 EDT
Investigating
Users may be experiencing an issue when attempting to send an Estimate or Invoice to a recipient. Our team is working to investigate the cause of the issue.
Posted 3 months ago. Aug 30, 2018 - 20:08 EDT
This incident affected: Mobile Applications and Web Application.