Issue with Cloud Provider

Incident Report for Dispatch

Update

We are continuing to monitor for any further issues.
Posted May 08, 2026 - 00:28 EDT

Monitoring

We are seeing improvements but continue to monitor
Posted May 07, 2026 - 23:09 EDT

Identified

Dispatch notification delivery is currently disrupted due to issues with our cloud provider.

Reports are also impacted by this issue.

We are working on a resolution.
Posted May 07, 2026 - 23:05 EDT
This incident affects: Notifications (Email, SMS, Inbox, Notifications Events) and Cloud Providers and 3rd Party Providers (Dashboards and Reports, AWS ec2-us-east-1).