Reporting Accessibility

Incident Report for Dispatch

Resolved

This incident has been resolved
Posted Apr 30, 2025 - 15:41 EDT

Investigating

We are actively investigating an issue accessing reports in Dispatch Work and Manage with our reporting provider. Users may not have access to reports at this time.
Posted Apr 30, 2025 - 15:07 EDT
This incident affected: Dashboards and Reports.