Web Application Performance Issue
Incident Report for Dispatch
Resolved
Our engineers have quickly identified and resolved the web application issues. All users can continue to use the web application as expected.
Posted 10 months ago. Dec 11, 2017 - 09:59 EST
Investigating
We're currently experiencing a connection issue with our web application. Our engineers are actively investigating to resolve the matters.
Posted 10 months ago. Dec 11, 2017 - 09:53 EST