Applications Degraded, AWS Hosting Provider
Incident Report for Dispatch
Resolved
Our hosting provider (AWS) has resolved the underlying issue affecting our customer portal and applications.
Posted about 1 year ago. Sep 14, 2017 - 15:59 EDT
Investigating
We are investigating an increased error from our hosting provider (AWS) that is affecting our customer portal and applications.
Posted about 1 year ago. Sep 14, 2017 - 15:11 EDT