Application Accessibility
Incident Report for Dispatch
Resolved
This incident has been resolved.
Posted Jul 09, 2020 - 11:04 EDT
Investigating
Users may be experiencing issues accessing our Web application, work.dispatch.me, as well as our Mobile Apps. Our team is actively investigating - we'll provide an update shortly.
Posted Jul 09, 2020 - 10:21 EDT
This incident affected: Mobile Applications and Web Application.