Issues accessing some of our web applications
Incident Report for Dispatch
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 29, 2018 - 17:29 EDT
Investigating
We are investigating an issue with an external provider outside of our network which may be impacting Internet connectivity between some customer networks and Dispatch applications
Posted 3 months ago. Jun 29, 2018 - 14:50 EDT