Google Maps Outage Affecting Field and Manager App for Android Users
Incident Report for Dispatch
Resolved
This incident has been resolved.
Posted Apr 29, 2020 - 16:38 EDT
Update
We are continuing to monitor this situation. Android users experiencing this problem are encouraged to perform the following actions from their main device settings:

Go to Main Device Settings
Go to Apps
Go to Dispatch Apps (Field and Manager)
Go to Storage
Clear Cache >
Clear Data
Posted Apr 27, 2020 - 13:46 EDT
Monitoring
Due to an ongoing issue with Google Maps that Google has been working on since yesterday evening, users of our Manager or Field apps may experience crashing upon opening or trying to click into a job. This affects Android users. We recommend anyone experiencing recurring application crashes in Dispatch Field and Dispatch Manager to perform the follow actions from their main device settings:

Go to Main Device Settings
Go to Apps
Go to Dispatch App (Field and Manager)
Go to Storage
Clear Cache
Clear Data

If after following these steps users are still reporting issues, please delete and re-download our apps from the Google Play store.
Posted Apr 24, 2020 - 12:33 EDT
This incident affected: Mobile Applications.