Slowness accessing our main web application
Incident Report for Dispatch
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 02, 2018 - 15:47 EST
Investigating
We are currently investigating this issue.
Posted 3 months ago. Mar 02, 2018 - 15:14 EST