Email Notification Delay
Incident Report for Dispatch
Resolved
Email notification delivery has returned to normal operation - all delays have been resolved.
Posted 3 months ago. May 02, 2019 - 19:45 EDT
Update
We're continuing to monitor the email notification delay. There is no resolution ETA but an update will be provided upon further news.
Posted 3 months ago. May 02, 2019 - 18:11 EDT
Monitoring
There is a delay in email notifications reaching users and customers. We're monitoring the status of our email delivery service provider and will report back as updates are available.
Posted 3 months ago. May 02, 2019 - 17:25 EDT
This incident affected: Notifications (Email).