Invoices/Estimates Partially Functional
Incident Report for Dispatch
Resolved
Services have been restored to normal operation for creating and editing Invoices & Estimates across applications.
Posted Nov 05, 2019 - 13:23 EST
Update
Our team is continuing to work on a resolution to restore the use of Invoices & Estimates to normal operation.
Posted Nov 05, 2019 - 12:39 EST
Identified
Users are experiencing challenges creating and/or editing Invoices & Estimates due to an issue with Billing Items. Our engineers have identified the root problem and are quickly working to restore back to normal operation.
Posted Nov 05, 2019 - 11:54 EST
This incident affected: Mobile Applications and Web Application.