Slow response in applications
Incident Report for Dispatch
Resolved
Our engineers have quickly identified and quickly resolved the slow experience. Users are able to operate within our application as usual.
Posted about 1 year ago. Jun 06, 2018 - 13:41 EDT
Investigating
We've noticed slow application response for users and our engineering team are on top of investigating and working the resolution as soon as possible.
Posted about 1 year ago. Jun 06, 2018 - 13:28 EDT